aboutsummaryrefslogtreecommitdiff
path: root/package/kernel
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-11-19 12:52:55 +0100
committerRafał Miłecki <rafal@milecki.pl>2024-01-26 17:52:24 +0100
commit1b3259eb5cdcfecbfae7809b8a9febdbe22ac65f (patch)
tree8c6a01ed5b90a307c92f5ef4ebeb9ffabaf926cf /package/kernel
parent0fd3a6c6c6f079565f1f5de4709f3d4d71fc54c8 (diff)
generic: 5.15: backport upstream Aquantia PHY firmware loader patches
Backport merged upstream patch that adds support for firmware loader from NVMEM or attached filesystem for Aquantia PHYs. Refresh all kernel patches affected by this change. Also update the path for aquantia .ko that got moved to dedicated directory upstream. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com> [rmilecki: port to 5.15] Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/netdevices.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 46dcdfdef7..63f75e9591 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -380,9 +380,7 @@ define KernelPackage/phy-aquantia
TITLE:=Aquantia Ethernet PHYs
DEPENDS:=+kmod-libphy +kmod-hwmon-core +kmod-lib-crc-ccitt
KCONFIG:=CONFIG_AQUANTIA_PHY
- FILES:= \
- $(LINUX_DIR)/drivers/net/phy/aquantia.ko@lt6.1 \
- $(LINUX_DIR)/drivers/net/phy/aquantia/aquantia.ko@ge6.1
+ FILES:=$(LINUX_DIR)/drivers/net/phy/aquantia/aquantia.ko
AUTOLOAD:=$(call AutoLoad,18,aquantia,1)
endef