aboutsummaryrefslogtreecommitdiff
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2024-03-05 13:22:11 +0100
committerZoltan HERPAI <wigyori@uid0.hu>2024-03-17 00:19:20 +0100
commitafd5926e37b82561c5ddb30c4c672d207b3d50e9 (patch)
treee73148b4adb7d6ed7f48e0e009559c57ddaa6b8d /package/kernel/linux
parentdea42f67ab06a8f2c1e6338f9829d31a28642317 (diff)
hwmon: add TC654 fan-controller support
Add support for the Microchip TC654 PWM fan-controller. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/hwmon.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 5be63ce779..be38a6071a 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -572,6 +572,21 @@ endef
$(eval $(call KernelPackage,hwmon-sht3x))
+define KernelPackage/hwmon-tc654
+ TITLE:=TC654 monitoring support
+ KCONFIG:=CONFIG_SENSORS_TC654
+ FILES:=$(LINUX_DIR)/drivers/hwmon/tc654.ko
+ AUTOLOAD:=$(call AutoLoad,60,tc654)
+ $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-tc654/description
+ Kernel module for Microchip TC654/TC655 and compatibles
+endef
+
+$(eval $(call KernelPackage,hwmon-tc654))
+
+
define KernelPackage/hwmon-tmp102
TITLE:=Texas Instruments TMP102 monitoring support
KCONFIG:=CONFIG_SENSORS_TMP102