aboutsummaryrefslogtreecommitdiff
path: root/package/firmware/ipq-wifi
diff options
context:
space:
mode:
authorMantas Pucka <mantas@8devices.com>2024-01-03 11:25:59 +0200
committerRobert Marko <robimarko@gmail.com>2024-02-21 21:42:23 +0100
commit10ba730b7bcb7d9c4d73ac0956fa18f06deb0e52 (patch)
tree0fde2a0d246db5cd226c850f637566a93c29cf09 /package/firmware/ipq-wifi
parent03935cf7de8c20549ceedab8ae5aeb05c59e92a0 (diff)
ipq-wifi: add support for 8devices Mango board
Add support for .ipq6018 BDF suffix and add Mango board entry Signed-off-by: Mantas Pucka <mantas@8devices.com>
Diffstat (limited to 'package/firmware/ipq-wifi')
-rw-r--r--package/firmware/ipq-wifi/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/firmware/ipq-wifi/Makefile b/package/firmware/ipq-wifi/Makefile
index eae84c7835..2b53d3e21b 100644
--- a/package/firmware/ipq-wifi/Makefile
+++ b/package/firmware/ipq-wifi/Makefile
@@ -28,6 +28,7 @@ endef
# <https://wireless.wiki.kernel.org/en/users/drivers/ath10k/boardfiles>
ALLWIFIBOARDS:= \
+ 8devices_mango \
arcadyan_aw1000 \
buffalo_wxr-5950ax12 \
cmcc_rm2-6 \
@@ -85,12 +86,14 @@ define ipq-wifi-install-one
$(call ipq-wifi-install-one-to,$(1),$(2),QCA9984/hw1.0),\
$(if $(filter $(suffix $(1)),.QCA99X0 .qca99x0),\
$(call ipq-wifi-install-one-to,$(1),$(2),QCA99X0/hw2.0),\
+ $(if $(filter $(suffix $(1)),.IPQ6018 .ipq6018),\
+ $(call ipq-wifi-install-ath11-one-to,$(1),$(2),IPQ6018/hw1.0),\
$(if $(filter $(suffix $(1)),.IPQ8074 .ipq8074 .ipq8174),\
$(call ipq-wifi-install-ath11-one-to,$(1),$(2),IPQ8074/hw2.0),\
$(if $(filter $(suffix $(1)),.QCN9074 .qcn9074),\
$(call ipq-wifi-install-ath11-one-to,$(1),$(2),QCN9074/hw1.0),\
$(error Unrecognized board-file suffix '$(suffix $(1))' for '$(1)')\
- )))))))
+ ))))))))
endef
# Blank line required at end of above define due to foreach context
@@ -140,6 +143,7 @@ endef
# Board files should follow this name structure:
# board-<devicename>.<qca4019|qca9888|qca9889|qca9984|qca99x0|ipq8074>
+$(eval $(call generate-ipq-wifi-package,8devices_mango,8devices Mango))
$(eval $(call generate-ipq-wifi-package,arcadyan_aw1000,Arcadyan AW1000))
$(eval $(call generate-ipq-wifi-package,buffalo_wxr-5950ax12,Buffalo WXR-5950AX12))
$(eval $(call generate-ipq-wifi-package,cmcc_rm2-6,CMCC RM2-6))