aboutsummaryrefslogtreecommitdiff
path: root/package/boot/uboot-sunxi/Makefile
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2020-03-05 21:54:53 +0100
committerZoltan HERPAI <wigyori@uid0.hu>2023-08-11 18:04:44 +0200
commit80edfaf675364835e6d2e17d97ebec6afc6b2103 (patch)
tree081d089863f5ff0d496826230f35d9f97aa253eb /package/boot/uboot-sunxi/Makefile
parentdc122f4d9e44adfd73c27111b00210ad2c0c3555 (diff)
sunxi: add support for Banana Pi M3
CPU Allwinner A83t Octa-core Cortex A7 @ 1.2GHz Memory 2Gb DDR3 Storage SDcard, SATA (via USB), 8GB eMMC Network 10/100/1000M ethernet, Ampak AP6212 wifi + BT USB 2x USB 2.0 Flashing instructions: Standard sunxi SD card installation procedure - copy image to SD card, insert into SD card slot on the device and boot. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Diffstat (limited to 'package/boot/uboot-sunxi/Makefile')
-rw-r--r--package/boot/uboot-sunxi/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index cb0c93281d..7cadf6ff32 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -294,6 +294,12 @@ define U-Boot/bananapi_m2_plus_h3
BUILD_DEVICES:=sinovoip_bananapi-m2-plus
endef
+define U-Boot/Sinovoip_BPI_M3
+ BUILD_SUBTARGET:=cortexa7
+ NAME:=Bananapi M3
+ BUILD_DEVICES:=sinovoip_bananapi-m3
+endef
+
define U-Boot/sopine_baseboard
BUILD_SUBTARGET:=cortexa53
NAME:=Sopine Baseboard
@@ -378,6 +384,7 @@ UBOOT_TARGETS := \
orangepi_pc2 \
pangolin \
pine64_plus \
+ Sinovoip_BPI_M3 \
sopine_baseboard \
orangepi_zero_plus \
libretech_all_h3_cc_h5