aboutsummaryrefslogtreecommitdiff
path: root/package/boot/uboot-sunxi/Makefile
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2023-09-02 00:18:18 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2023-09-18 00:08:19 +0200
commit12584395dc5d45333df298554ff73a8b9495e119 (patch)
tree8faaf260a8dfb23ab33d254df845f18325147d05 /package/boot/uboot-sunxi/Makefile
parent794349a28a7b9036b54e13487a96120609db924e (diff)
sunxi: add support for H616 SoC and Orangepi Zero 2
Specifications: SoC: Allwinner H616 @ 1.5 Ghz DRAM: 1Gb LPDDR3 Power: 5V USB-C Video: HDMI (Type 2.0A - micro) Network: 10/100/1000Mbps Ethernet (Realtek RTL8211F), AW859A BT+wifi Storage: microSD / 2Mb SPI flash USB: 1 USB2.0 Host Debug Serial UART Flashing instructions: Standard sunxi SD card installation procedure - copy image to SD card, insert into SD card slot on the device and boot. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Diffstat (limited to 'package/boot/uboot-sunxi/Makefile')
-rw-r--r--package/boot/uboot-sunxi/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index be4c8411a9..e141eb7af7 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -328,6 +328,15 @@ define U-Boot/orangepi_pc2
ATF:=a64
endef
+define U-Boot/orangepi_zero2
+ BUILD_SUBTARGET:=cortexa53
+ NAME:=Xunlong Orange Pi Zero2
+ BUILD_DEVICES:=xunlong_orangepi-zero2
+ DEPENDS:=+PACKAGE_u-boot-orangepi_zero2:trusted-firmware-a-sunxi-h616
+ UENV:=h616
+ ATF:=h616
+endef
+
define U-Boot/Bananapi_M2_Ultra
BUILD_SUBTARGET:=cortexa7
NAME:=Bananapi M2 Ultra
@@ -382,6 +391,7 @@ UBOOT_TARGETS := \
orangepi_plus \
orangepi_2 \
orangepi_pc2 \
+ orangepi_zero2 \
pangolin \
pine64_plus \
Sinovoip_BPI_M3 \