aboutsummaryrefslogtreecommitdiff
path: root/package/boot/uboot-oxnas/Makefile
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2024-04-24 07:19:30 +0200
committerNick Hainke <vincent@systemli.org>2024-04-24 14:12:15 +0200
commit6ca830559865f994db8732a9d06f452e36d5b490 (patch)
tree9d31a37373763dcc5c7f6eff5234ebc111dfa99e /package/boot/uboot-oxnas/Makefile
parent98cc65d9a0c4e7beb4b9a8f8482ab8908435290b (diff)
oxnas: drop target
The Upstream Linux community has discontinued support for the target. Maintaining support for it downstream would require too much effort. Moreover, it seems that the supported hardware is no longer deemed worthy of it. Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'package/boot/uboot-oxnas/Makefile')
-rw-r--r--package/boot/uboot-oxnas/Makefile36
1 files changed, 0 insertions, 36 deletions
diff --git a/package/boot/uboot-oxnas/Makefile b/package/boot/uboot-oxnas/Makefile
deleted file mode 100644
index fc06f01dcb..0000000000
--- a/package/boot/uboot-oxnas/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-#
-# Copyright (C) 2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_VERSION:=2014.10
-PKG_RELEASE:=16
-
-PKG_HASH:=d3b132a7a9b3f3182b7aad71c2dfbd4fc15bea83e12c76134eb3ffefc07d1c71
-
-include $(INCLUDE_DIR)/u-boot.mk
-include $(INCLUDE_DIR)/package.mk
-
-define U-Boot/Default
- BUILD_TARGET:=oxnas
- BUILD_DEVICES:=Default
- HIDDEN:=y
-endef
-
-define U-Boot/ox820
- NAME:=Oxford/PLX NAS7820
-endef
-
-UBOOT_TARGETS:=ox820
-
-define Build/InstallDev
- $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
- $(CP) $(PKG_BUILD_DIR)/u-boot.bin $(STAGING_DIR_IMAGE)/u-boot.bin
-endef
-
-$(eval $(call BuildPackage/U-Boot))