aboutsummaryrefslogtreecommitdiff
path: root/package/boot/rkbin
diff options
context:
space:
mode:
authorMarius Durbaca <mariusd84@gmail.com>2024-02-19 18:33:24 +0000
committerNick Hainke <vincent@systemli.org>2024-02-21 13:29:26 +0100
commiteec0bec630116ce61c3be273552d9d78397c7acc (patch)
tree4f5c7a6e5105ff59ddaba4965cf3ffcd93a2a7f8 /package/boot/rkbin
parent95e633efbd1b4ffbbfc2d8abba2b05291f6e9903 (diff)
rkbin: add rk3566 atf/tpl blobs
Currently there are no atf/tpl blobs for rk3566 SoCs so this commit adds the prebuilt firmware from the vendor. Signed-off-by: Marius Durbaca <mariusd84@gmail.com>
Diffstat (limited to 'package/boot/rkbin')
-rw-r--r--package/boot/rkbin/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/boot/rkbin/Makefile b/package/boot/rkbin/Makefile
index affdd7b4e1..bb116bdcd2 100644
--- a/package/boot/rkbin/Makefile
+++ b/package/boot/rkbin/Makefile
@@ -25,6 +25,12 @@ define Trusted-Firmware-A/Default
BUILD_TARGET:=rockchip
endef
+define Trusted-Firmware-A/rk3566
+ BUILD_SUBTARGET:=armv8
+ ATF:=rk35/rk3568_bl31_v1.43.elf
+ TPL:=rk35/rk3566_ddr_1056MHz_v1.18.bin
+endef
+
define Trusted-Firmware-A/rk3568
BUILD_SUBTARGET:=armv8
ATF:=rk35/rk3568_bl31_v1.43.elf
@@ -32,6 +38,7 @@ define Trusted-Firmware-A/rk3568
endef
TFA_TARGETS:= \
+ rk3566 \
rk3568
define Build/Compile