aboutsummaryrefslogtreecommitdiff
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2023-11-09 10:53:02 -0800
committerPaul Spooren <mail@aparcar.org>2023-11-12 12:15:55 +0100
commit7ceb76ca3a37ba6b722df39ba0838909fa7cf7b4 (patch)
tree6a124aa36d3b920b64b93542541629a48760dd7b /include/prereq-build.mk
parent36b1dd75fd9da1ea13f1ce1ee679c6b3c9c402cc (diff)
prereq-build: add Python 3.12 support
Fixes build on Fedora 39. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 49340ce3e4..2378f5ad90 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -182,6 +182,7 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
perl --version | grep "perl.*v5"))
$(eval $(call SetupHostCommand,python,Please install Python >= 3.7, \
+ python3.12 -V 2>&1 | grep 'Python 3', \
python3.11 -V 2>&1 | grep 'Python 3', \
python3.10 -V 2>&1 | grep 'Python 3', \
python3.9 -V 2>&1 | grep 'Python 3', \
@@ -190,6 +191,7 @@ $(eval $(call SetupHostCommand,python,Please install Python >= 3.7, \
python3 -V 2>&1 | grep -E 'Python 3\.([7-9]|[0-9][0-9])\.?'))
$(eval $(call SetupHostCommand,python3,Please install Python >= 3.7, \
+ python3.12 -V 2>&1 | grep 'Python 3', \
python3.11 -V 2>&1 | grep 'Python 3', \
python3.10 -V 2>&1 | grep 'Python 3', \
python3.9 -V 2>&1 | grep 'Python 3', \