aboutsummaryrefslogtreecommitdiff
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorIlya Katsnelson <me@0upti.me>2023-10-30 01:39:31 +0300
committerDavid Bauer <mail@david-bauer.net>2023-11-03 23:06:07 +0100
commit2c22589782d74e9db5d79f72b259df08beb5ef7a (patch)
tree54e23f0d93967ea0f8c5c78bf8ab6fd588b43308 /include/prereq-build.mk
parent45a50a06fb3f39ea70936dd967a74e6e96f0cd89 (diff)
build: replace `true` with a custom noop script
`true` might be a shell built-in, or simply not accessible in the hardcoded locations. Replace it with a custom script that does nothing. Signed-off-by: Ilya Katsnelson <me@0upti.me>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index e5f20fff22..49340ce3e4 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -238,4 +238,4 @@ prereq: $(STAGING_DIR_HOST)/bin/mkhash $(STAGING_DIR_HOST)/bin/xxd
# Install ldconfig stub
$(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \
- $(LN) $(firstword $(wildcard /bin/true /usr/bin/true)) $(STAGING_DIR_HOST)/bin/ldconfig))
+ $(LN) $(SCRIPT_DIR)/noop.sh $(STAGING_DIR_HOST)/bin/ldconfig))