aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLinus Walleij <linus.walleij@linaro.org>2023-10-23 08:43:03 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-10-25 11:23:57 +0200
commitfcd1c9cbcc89f3822575e43e10488dcfae76f9c0 (patch)
treeae922f532332b3712fd8a01cdcfb9d7de00d880d
parent330492a101cdb1608d1194496c1b620315ef8bd8 (diff)
kernel: netdevices: Package AMD PHY
This adds a package for the AMD and Altima PHY, found in some odd devices. Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
-rw-r--r--package/kernel/linux/modules/netdevices.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index b0d69e0220..9057ec5615 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -224,6 +224,22 @@ endef
$(eval $(call KernelPackage,phylib-broadcom))
+define KernelPackage/phy-amd
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=AMD PHY driver
+ KCONFIG:=CONFIG_AMD_PHY
+ DEPENDS:=+kmod-libphy
+ FILES:=$(LINUX_DIR)/drivers/net/phy/amd.ko
+ AUTOLOAD:=$(call AutoProbe,amd,1)
+endef
+
+define KernelPackage/phy-amd/description
+ Currently supports the AMD and Altima PHYs.
+endef
+
+$(eval $(call KernelPackage,phy-amd))
+
+
define KernelPackage/phy-ax88796b
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Asix PHY driver