aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-11-25 23:22:59 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-11-26 19:44:56 +0100
commitfb3af8611942feb24f9b51934d8d1901050bf0d9 (patch)
treea33b49ffeaca7e5d4671d1045286f8fdc7aa823f
parent20f81f49eacdca75046e3f3e0d26ee456aa28eac (diff)
uboot-sifiveu: use intree dtc explicitly
This replaces pylibfdt hack. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
-rw-r--r--package/boot/uboot-sifiveu/Makefile2
-rw-r--r--package/boot/uboot-sifiveu/patches/300-force-pylibfdt-build.patch30
2 files changed, 2 insertions, 30 deletions
diff --git a/package/boot/uboot-sifiveu/Makefile b/package/boot/uboot-sifiveu/Makefile
index 5def1c1fcb..4cbfe344af 100644
--- a/package/boot/uboot-sifiveu/Makefile
+++ b/package/boot/uboot-sifiveu/Makefile
@@ -10,6 +10,8 @@ PKG_RELEASE:=1
PKG_VERSION:=2022.10
PKG_HASH:=50b4482a505bc281ba8470c399a3c26e145e29b23500bc35c50debd7fa46bdf8
+UBOOT_USE_INTREE_DTC:=1
+
include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
diff --git a/package/boot/uboot-sifiveu/patches/300-force-pylibfdt-build.patch b/package/boot/uboot-sifiveu/patches/300-force-pylibfdt-build.patch
deleted file mode 100644
index 4abf13eda8..0000000000
--- a/package/boot/uboot-sifiveu/patches/300-force-pylibfdt-build.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -2028,26 +2028,7 @@ endif
- # Check dtc and pylibfdt, if DTC is provided, else build them
- PHONY += scripts_dtc
- scripts_dtc: scripts_basic
-- $(Q)if test "$(DTC)" = "$(DTC_INTREE)"; then \
-- $(MAKE) $(build)=scripts/dtc; \
-- else \
-- if ! $(DTC) -v >/dev/null; then \
-- echo '*** Failed to check dtc version: $(DTC)'; \
-- false; \
-- else \
-- if test "$(call dtc-version)" -lt $(DTC_MIN_VERSION); then \
-- echo '*** Your dtc is too old, please upgrade to dtc $(DTC_MIN_VERSION) or newer'; \
-- false; \
-- else \
-- if [ -n "$(CONFIG_PYLIBFDT)" ]; then \
-- if ! echo "import libfdt" | $(PYTHON3) 2>/dev/null; then \
-- echo '*** pylibfdt does not seem to be available with $(PYTHON3)'; \
-- false; \
-- fi; \
-- fi; \
-- fi; \
-- fi; \
-- fi
-+ $(MAKE) $(build)=scripts/dtc
-
- # ---------------------------------------------------------------------------
- quiet_cmd_cpp_lds = LDS $@