aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2023-05-30 22:00:19 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2023-05-31 21:28:37 +0200
commit3c55d8698a4a8236939a551d44adb6dbfea7c085 (patch)
treeaf13aef412b6ccfe7511112502dabcbf3efd4eee
parentfd572feef80c2366af7ce68775708b21948e1018 (diff)
kernel: Make kmod-phylink depend on kmod-libphy
The CONFIG_PHYLINK Kconfig option in the kernel selects CONFIG_LIBPHY. Add this dependency to fix the all kernel modules build on MIPS malta and armvirt with kernel 6.1. With kernel 5.15 mod-phylink and kmod-sfp are empty packages because no OpenWrt kmod is selecting a module which needs sfp or phylink support. Fixes: #12758 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--package/kernel/linux/modules/netdevices.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 934ba3c4f2..948902cf63 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -111,6 +111,7 @@ $(eval $(call KernelPackage,libphy))
define KernelPackage/phylink
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Model for MAC to optional PHY connection
+ DEPENDS:=+kmod-libphy
KCONFIG:=CONFIG_PHYLINK
FILES:=$(LINUX_DIR)/drivers/net/phy/phylink.ko
AUTOLOAD:=$(call AutoLoad,15,phylink,1)