aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-11-08 16:46:12 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-11-09 15:58:37 +0100
commit1b5ea2e199fcf391f88afd0322de449459399be4 (patch)
treeb3ca6c4aec58145f8fdecf55249e8b0a07663aed
parent1070fbce6e496da2dacf17c6e842a4369c4be71b (diff)
hostapd: fix broke noscan option for mesh
noscan option for mesh was broken and actually never applied. This is caused by a typo where ssid->noscan value is check instead of conf->noscan resulting in the logic swapped and broken. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/hostapd/patches/301-mesh-noscan.patch4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 73ec5e198d..f46c6275ef 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -5,7 +5,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/hostapd/patches/301-mesh-noscan.patch b/package/network/services/hostapd/patches/301-mesh-noscan.patch
index 6b5416f0ea..0e654febd5 100644
--- a/package/network/services/hostapd/patches/301-mesh-noscan.patch
+++ b/package/network/services/hostapd/patches/301-mesh-noscan.patch
@@ -24,8 +24,8 @@
frequency);
goto out_free;
}
-+ if (ssid->noscan)
-+ conf->noscan = 1;
++ if (conf->noscan)
++ ssid->noscan = 1;
if (ssid->mesh_basic_rates == NULL) {
/*