aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2023-07-28 22:40:34 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2023-08-03 17:39:39 +0300
commit15acde674c76504e023a525506a2e248e9aecd24 (patch)
tree41e418bf870ca7e019710ee5174125880d7bb420
parent57fda4b743ecf06c217d2670002313d528ff817a (diff)
xdp-tools: disable stack protector for BPF programs
When building xdp-tools with CONFIG_USE_LLVM_HOST=y, on a host that enabled stack protector by default in Clang, compilation fails with the following error: CLANG xdp-dispatcher.o clang-16: error: ignoring '-fstack-protector-strong' option as it is not currently supported for target 'bpfeb' [-Werror,-Woption-ignored] Add -fno-stack-protector to BPF_CFLAGS to fix this. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
-rw-r--r--package/network/utils/xdp-tools/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/utils/xdp-tools/Makefile b/package/network/utils/xdp-tools/Makefile
index 3cc7980cf6..dba775e4ea 100644
--- a/package/network/utils/xdp-tools/Makefile
+++ b/package/network/utils/xdp-tools/Makefile
@@ -94,7 +94,7 @@ MAKE_VARS += \
define Build/Configure
$(call Build/Configure/Default)
- echo "BPF_CFLAGS += -I$(BPF_HEADERS_DIR)/tools/lib" >> $(PKG_BUILD_DIR)/config.mk
+ echo "BPF_CFLAGS += -I$(BPF_HEADERS_DIR)/tools/lib -fno-stack-protector" >> $(PKG_BUILD_DIR)/config.mk
endef
define Build/InstallDev