aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2023-11-14 09:47:38 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-11-14 05:21:55 +0100
commit14aeb471f2b3bbb8095e8f9e9625caee594b58e7 (patch)
tree51517de5c7339e041bca2f7969e224e00d93fcfd
parent853db7be9521e67588acaf15e5600d911e5f8253 (diff)
qca-ssdk: disable PTP and swconfig by default
PTP and swconfig support in SSDK require kernel modifications we dont need nor we want to support for now, so move the PTP and swconfig disablement into general build options as they are not ipq807x specific. Signed-off-by: Robert Marko <robimarko@gmail.com>
-rw-r--r--package/kernel/qca-ssdk/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/qca-ssdk/Makefile b/package/kernel/qca-ssdk/Makefile
index ab978f3b49..3770d29e8c 100644
--- a/package/kernel/qca-ssdk/Makefile
+++ b/package/kernel/qca-ssdk/Makefile
@@ -44,10 +44,11 @@ MAKE_FLAGS+= \
GCC_VERSION=$(GCC_VERSION) \
EXTRA_CFLAGS=-fno-stack-protector -I$(STAGING_DIR)/usr/include \
SoC=$(CONFIG_TARGET_SUBTARGET) \
+ PTP_FEATURE=disable SWCONFIG_FEATURE=disable \
$(LNX_CONFIG_OPTS)
ifeq ($(CONFIG_TARGET_SUBTARGET), "ipq807x")
- MAKE_FLAGS+= CHIP_TYPE=HPPE PTP_FEATURE=disable SWCONFIG_FEATURE=disable
+ MAKE_FLAGS+= CHIP_TYPE=HPPE
endif
define Build/InstallDev