aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
Diffstat (limited to 'utils')
-rw-r--r--utils/sedutil/Makefile2
-rw-r--r--utils/sedutil/patches/010-gcc13.patch25
2 files changed, 26 insertions, 1 deletions
diff --git a/utils/sedutil/Makefile b/utils/sedutil/Makefile
index 9625459d6..64c77232f 100644
--- a/utils/sedutil/Makefile
+++ b/utils/sedutil/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=sedutil
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=https://github.com/Drive-Trust-Alliance/sedutil
diff --git a/utils/sedutil/patches/010-gcc13.patch b/utils/sedutil/patches/010-gcc13.patch
new file mode 100644
index 000000000..d60984d13
--- /dev/null
+++ b/utils/sedutil/patches/010-gcc13.patch
@@ -0,0 +1,25 @@
+From b47102bf6066e5342fdbb69bd767cd70a0a59bf9 Mon Sep 17 00:00:00 2001
+From: Yaakov Selkowitz <yselkowi@redhat.com>
+Date: Sun, 19 Feb 2023 21:28:10 -0500
+Subject: [PATCH] Fix build with GCC 13
+
+As in previous versions, libstdc++ in GCC 13 has trimmed internal
+inclusion of standard headers, necessitating their proper inclusion
+when used:
+
+https://gcc.gnu.org/gcc-13/porting_to.html
+---
+ Common/DtaOptions.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+--- a/Common/DtaOptions.h
++++ b/Common/DtaOptions.h
+@@ -21,6 +21,8 @@ along with sedutil. If not, see <http:/
+ #ifndef _DTAOPTIONS_H
+ #define _DTAOPTIONS_H
+
++#include <stdint.h>
++
+ /** Output modes */
+ typedef enum _sedutiloutput {
+ sedutilNormal,