aboutsummaryrefslogtreecommitdiff
path: root/utils/uvol/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'utils/uvol/Makefile')
-rw-r--r--utils/uvol/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/utils/uvol/Makefile b/utils/uvol/Makefile
index f470e5143..f929ba515 100644
--- a/utils/uvol/Makefile
+++ b/utils/uvol/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uvol
-PKG_VERSION:=0.2
+PKG_VERSION:=0.3
PKG_RELEASE:=$(AUTORELEASE)
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
@@ -28,6 +28,7 @@ define Package/uvol
CATEGORY:=Utilities
SUBMENU:=Disc
TITLE:=OpenWrt UBI/LVM volume abstraction
+ DEPENDS:=+blockd
PKGARCH=all
endef
@@ -63,8 +64,9 @@ define Package/autopart/install
endef
define Package/uvol/install
- $(INSTALL_DIR) $(1)/etc/init.d $(1)/usr/libexec/uvol $(1)/usr/sbin
+ $(INSTALL_DIR) $(1)/etc/init.d $(1)/usr/libexec/uvol $(1)/usr/sbin $(1)/lib/functions
$(INSTALL_BIN) ./files/uvol.init $(1)/etc/init.d/uvol
+ $(INSTALL_BIN) ./files/common.sh $(1)/lib/functions/uvol.sh
$(INSTALL_BIN) ./files/ubi.sh $(1)/usr/libexec/uvol/20-ubi.sh
$(INSTALL_BIN) ./files/lvm.sh $(1)/usr/libexec/uvol/50-lvm.sh
$(INSTALL_BIN) ./files/uvol $(1)/usr/sbin