aboutsummaryrefslogtreecommitdiff
path: root/utils/mqttled/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'utils/mqttled/Makefile')
-rw-r--r--utils/mqttled/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/utils/mqttled/Makefile b/utils/mqttled/Makefile
new file mode 100644
index 000000000..1620fe155
--- /dev/null
+++ b/utils/mqttled/Makefile
@@ -0,0 +1,58 @@
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mqttled
+PKG_VERSION:=0.1.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=mqttled
+PKG_HASH:=20f46b7114b6ddace6e0faaaa078640f609c3d495e4ccff8d8caeb77ac5418f7
+
+PKG_MAINTAINER:=Tom Grime <tom.grime@gmail.com>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENCE
+
+include ../../lang/python/pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../../lang/python/python3-package.mk
+
+define Package/mqttled
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=LED Control from MQTT
+ URL:=https://github.com/trevortrevor/mqttled/
+ DEPENDS:= \
+ +python3-paho-mqtt \
+ +python3-uci \
+ +python3-idna \
+ +python3-jsonpath-ng \
+ +python3-yaml \
+ +python3-schema \
+ +python3-netifaces \
+ +python3-logging \
+ +python3-urllib \
+ +python3-asyncio \
+ +python3-pkg-resources
+
+endef
+
+define Package/mqttled/description
+ Exposes the LEDs of your device to an MQTT broker with optional Home Assistant auto discovery
+endef
+
+define Py3Package/mqttled/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mqttled $(1)/usr/bin/
+
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/mqttled.init $(1)/etc/init.d/mqttled
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_DATA) ./files/mqttled.config $(1)/etc/config/mqttled
+endef
+
+define Package/mqttled/conffiles
+/etc/config/mqttled
+endef
+
+$(eval $(call Py3Package,mqttled))
+$(eval $(call BuildPackage,mqttled))