aboutsummaryrefslogtreecommitdiff
path: root/utils/mktorrent
diff options
context:
space:
mode:
Diffstat (limited to 'utils/mktorrent')
-rw-r--r--utils/mktorrent/Makefile2
-rw-r--r--utils/mktorrent/patches/010-format.patch20
2 files changed, 21 insertions, 1 deletions
diff --git a/utils/mktorrent/Makefile b/utils/mktorrent/Makefile
index 3bc241a61..4afbba4b7 100644
--- a/utils/mktorrent/Makefile
+++ b/utils/mktorrent/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mktorrent
PKG_VERSION:=1.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
diff --git a/utils/mktorrent/patches/010-format.patch b/utils/mktorrent/patches/010-format.patch
new file mode 100644
index 000000000..e7f62b04f
--- /dev/null
+++ b/utils/mktorrent/patches/010-format.patch
@@ -0,0 +1,20 @@
+--- a/GNUmakefile
++++ b/GNUmakefile
+@@ -61,6 +61,6 @@ OBJS = $(SRCS:.c=.o)
+ all: $(program)
+
+ %.o: %.c $(HEADERS) prefix
+- $(CC) $(CFLAGS) $(DEFINES) -DPRIoff="\"$(OFFPRFX)d\"" -DVERSION="\"$(version)\"" -c $<
++ $(CC) $(CFLAGS) $(DEFINES) -DPRIoff="PRId64 \"d\"" -DVERSION="\"$(version)\"" -c $<
+
+ include rules.mk
+--- a/init.c
++++ b/init.c
+@@ -25,6 +25,7 @@ Foundation, Inc., 51 Franklin Street, Fi
+ #include <sys/stat.h> /* the stat structure */
+ #include <unistd.h> /* getopt(), getcwd(), sysconf() */
+ #include <string.h> /* strcmp(), strlen(), strncpy() */
++#include <inttypes.h>
+ #ifdef USE_LONG_OPTIONS
+ #include <getopt.h> /* getopt_long() */
+ #endif