aboutsummaryrefslogtreecommitdiff
path: root/utils/hplip/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'utils/hplip/Makefile')
-rw-r--r--utils/hplip/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/utils/hplip/Makefile b/utils/hplip/Makefile
index 6c1c85311..13499ca4f 100644
--- a/utils/hplip/Makefile
+++ b/utils/hplip/Makefile
@@ -9,17 +9,19 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hplip
-PKG_VERSION:=3.18.6
+PKG_VERSION:=3.18.9
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/hplip
-PKG_HASH:=0ecf3e68b09480f602de81798ac00774cf8ffe754692e784bbbe0f9b2e337b7d
+PKG_HASH:=20093830994de16bb36c049c1fdb688569531525fb994f7e605e66266a2d783c
+
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
PKG_LICENSE:=GPL-2.0 GPL-2.0+
PKG_LICENSE_FILES:=COPYING LICENSE
-PKG_BUILD_DEPENDS := python libcups
+PKG_BUILD_PARALLEL:=1
+PKG_BUILD_DEPENDS:= python libcups
PKG_FIXUP:=autoreconf
include $(INCLUDE_DIR)/package.mk
@@ -28,7 +30,7 @@ define Package/hplip/Default
SECTION:=utils
CATEGORY:=Utilities
TITLE:=HP Linux Imaging and Printing
- URL:=http://sourceforge.net/projects/hplip/
+ URL:=https://sourceforge.net/projects/hplip/
endef
define Package/hplip/Default/description
@@ -66,6 +68,10 @@ CONFIGURE_ARGS += \
--disable-pp-build \
--disable-doc-build \
--disable-dbus-build \
+ --disable-hpijs-only-build \
+ --disable-hpcups-install \
+ --disable-hpps-install \
+ --disable-cups-drv-install \
--enable-lite-build
define Package/hplip-common/install