aboutsummaryrefslogtreecommitdiff
path: root/utils/flashrom
diff options
context:
space:
mode:
Diffstat (limited to 'utils/flashrom')
-rw-r--r--utils/flashrom/Makefile2
-rw-r--r--utils/flashrom/patches/0002-fix-musl-compatibility.patch12
2 files changed, 13 insertions, 1 deletions
diff --git a/utils/flashrom/Makefile b/utils/flashrom/Makefile
index 702e63bed..af7b5e1dd 100644
--- a/utils/flashrom/Makefile
+++ b/utils/flashrom/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=flashrom
PKG_VERSION:=0.9.8
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://download.flashrom.org/releases
diff --git a/utils/flashrom/patches/0002-fix-musl-compatibility.patch b/utils/flashrom/patches/0002-fix-musl-compatibility.patch
new file mode 100644
index 000000000..b52f8b2f9
--- /dev/null
+++ b/utils/flashrom/patches/0002-fix-musl-compatibility.patch
@@ -0,0 +1,12 @@
+diff -uprN a/linux_spi.c b/linux_spi.c
+--- a/linux_spi.c 2015-06-17 20:50:36.492963100 +0200
++++ b/linux_spi.c 2015-06-17 20:50:00.444860800 +0200
+@@ -22,7 +22,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdlib.h>
+-#include <sys/fcntl.h>
++#include <fcntl.h>
+ #include <errno.h>
+ #include <ctype.h>
+ #include <unistd.h>