aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/tailscale/Makefile2
-rw-r--r--net/tailscale/files/tailscale.init3
2 files changed, 4 insertions, 1 deletions
diff --git a/net/tailscale/Makefile b/net/tailscale/Makefile
index 8cd236efb..48152ec90 100644
--- a/net/tailscale/Makefile
+++ b/net/tailscale/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tailscale
PKG_VERSION:=1.48.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/tailscale/tailscale/tar.gz/v$(PKG_VERSION)?
diff --git a/net/tailscale/files/tailscale.init b/net/tailscale/files/tailscale.init
index 6548fa220..7d5f52134 100644
--- a/net/tailscale/files/tailscale.init
+++ b/net/tailscale/files/tailscale.init
@@ -23,6 +23,9 @@ start_service() {
procd_open_instance
procd_set_param command /usr/sbin/tailscaled
+ # starting with v1.48.1 ENV variable is required to enable autodetection of iptables / nftables
+ procd_set_param env TS_DEBUG_FIREWALL_MODE=auto
+
# Set the port to listen on for incoming VPN packets.
# Remote nodes will automatically be informed about the new port number,
# but you might want to configure this in order to set external firewall