aboutsummaryrefslogtreecommitdiff
path: root/net/unbound
diff options
context:
space:
mode:
Diffstat (limited to 'net/unbound')
-rw-r--r--net/unbound/Makefile2
-rw-r--r--net/unbound/files/odhcpd.awk1
2 files changed, 2 insertions, 1 deletions
diff --git a/net/unbound/Makefile b/net/unbound/Makefile
index 58bcd4dfd..e414b038b 100644
--- a/net/unbound/Makefile
+++ b/net/unbound/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=unbound
PKG_VERSION:=1.6.7
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE
diff --git a/net/unbound/files/odhcpd.awk b/net/unbound/files/odhcpd.awk
index 58f28d29a..fa2e41edf 100644
--- a/net/unbound/files/odhcpd.awk
+++ b/net/unbound/files/odhcpd.awk
@@ -87,6 +87,7 @@
while ( ( cmd | getline adr ) > 0 ) {
if (( substr( adr, 1, 5 ) <= "fd00:" ) \
+ && ( index( adr, "anycast" ) == 0 ) \
&& ( index( adr, "via" ) == 0 )) {
# GA or ULA routed addresses only (not LL or MC)
sub( /\/.*/, "", adr ) ;