aboutsummaryrefslogtreecommitdiff
path: root/net/stubby/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/stubby/Makefile')
-rw-r--r--net/stubby/Makefile44
1 files changed, 19 insertions, 25 deletions
diff --git a/net/stubby/Makefile b/net/stubby/Makefile
index 97a17ae61..ca3b16472 100644
--- a/net/stubby/Makefile
+++ b/net/stubby/Makefile
@@ -6,46 +6,46 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=stubby
PKG_VERSION:=0.2.6
-PKG_RELEASE:=2
-
-PKG_LICENSE:=BSD-3-Clause
-PKG_LICENSE_FILES:=COPYING
-PKG_MAINTAINER:=Jonathan Underwood <jonathan.underwood@gmail.com>
+PKG_RELEASE:=3
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/getdnsapi/$(PKG_NAME)
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
PKG_MIRROR_HASH:=af896c471ac67b31c2263d11fcdfcdb32a213621c2f8789f4b0a4ceca4437108
-PKG_FIXUP:=autoreconf
+PKG_MAINTAINER:=Jonathan Underwood <jonathan.underwood@gmail.com>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=COPYING
+PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
define Package/stubby/Default
- TITLE:=stubby
- URL:=https://dnsprivacy.org/wiki/display/DP/DNS+Privacy+Daemon+-+Stubby
+ TITLE:=stubby
+ URL:=https://dnsprivacy.org/wiki/display/DP/DNS+Privacy+Daemon+-+Stubby
endef
define Package/stubby
- $(call Package/stubby/Default)
- SECTION:=net
- CATEGORY:=Network
- SUBMENU:=IP Addresses and Names
- TITLE+= - (daemon that uses getdns)
- USERID:=stubby=410:stubby=410
- DEPENDS:= +libyaml +getdns +ca-certs
+ $(call Package/stubby/Default)
+ SECTION:=net
+ CATEGORY:=Network
+ SUBMENU:=IP Addresses and Names
+ TITLE+= - (daemon that uses getdns)
+ USERID:=stubby=410:stubby=410
+ DEPENDS:= +libyaml +getdns +ca-certs
endef
define Package/stubby/description
- This package contains the Stubby daemon (which utilizes the getdns library).
-
- See https://github.com/openwrt/packages/blob/master/net/stubby/files/README.md for more details.
+ This package contains the Stubby daemon (which utilizes the getdns library).
+ See https://github.com/openwrt/packages/blob/master/net/stubby/files/README.md for more details.
endef
define Package/stubby/conffiles
/etc/stubby/stubby.yml
+/etc/config/stubby
endef
define Package/stubby/install
@@ -57,13 +57,7 @@ define Package/stubby/install
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/stubby/stubby.yml $(1)/etc/stubby/stubby.yml.default
$(INSTALL_DATA) ./files/stubby.yml $(1)/etc/stubby/stubby.yml
$(INSTALL_DIR) $(1)/etc/config
- $(INSTALL_DATA) ./files/stubby.conf $(1)/etc/config/stubby
-endef
-
-
-define Package/stubby/conffiles
- /etc/stubby/stubby.yml
- /etc/config/stubby
+ $(INSTALL_CONF) ./files/stubby.conf $(1)/etc/config/stubby
endef
$(eval $(call BuildPackage,stubby))