aboutsummaryrefslogtreecommitdiff
path: root/net/samplicator
diff options
context:
space:
mode:
Diffstat (limited to 'net/samplicator')
-rw-r--r--net/samplicator/Makefile13
-rw-r--r--net/samplicator/files/samplicator.init3
-rw-r--r--net/samplicator/patches/010-format.patch11
3 files changed, 11 insertions, 16 deletions
diff --git a/net/samplicator/Makefile b/net/samplicator/Makefile
index 882e2733b..667d595d4 100644
--- a/net/samplicator/Makefile
+++ b/net/samplicator/Makefile
@@ -1,17 +1,22 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=samplicator
-PKG_VERSION:=1.3.6
PKG_RELEASE:=$(AUTORELEASE)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/sleinen/samplicator/releases/download/v$(PKG_VERSION)
-PKG_HASH:=3c4358b4b0992a77251f2b9e2221d4ae945781160732c73504eb126e69d72d40
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/sleinen/samplicator.git
+PKG_SOURCE_DATE:=2021-10-11
+PKG_SOURCE_VERSION:=ceeb1d280188c155b71d819282490be86190f6f6
+PKG_MIRROR_HASH:=e96ac711313d3554d53ca8de5061b8fb18dfeb2823c4c0fe3404ba3b71e8b689
PKG_MAINTAINER:=Nick Hainke <vincent@systemli.org>
PKG_LICENSE:=GPL-2.0-only
PKG_LICENSE_FILES:=COPYING
+PKG_FIXUP:=autoreconf
+PKG_REMOVE_FILES:=autogen.sh
+PKG_BUILD_PARALLEL:=1
+
include $(INCLUDE_DIR)/package.mk
define Package/samplicator
diff --git a/net/samplicator/files/samplicator.init b/net/samplicator/files/samplicator.init
index f0e8f4278..0766d397f 100644
--- a/net/samplicator/files/samplicator.init
+++ b/net/samplicator/files/samplicator.init
@@ -5,11 +5,12 @@ START=70
SAMPLICATOR_BIN="/usr/sbin/samplicate"
SAMPLICATOR_CONF="/etc/samplicator.conf"
+PIDFILE="/var/run/samplicator.pid"
start_service() {
mkdir -p /var/run
procd_open_instance
- procd_set_param command $SAMPLICATOR_BIN -c $SAMPLICATOR_CONF
+ procd_set_param command $SAMPLICATOR_BIN -c $SAMPLICATOR_CONF -m $PIDFILE
procd_set_param file "$SAMPLICATOR_CONF"
procd_set_param stdout 1
procd_set_param stderr 1
diff --git a/net/samplicator/patches/010-format.patch b/net/samplicator/patches/010-format.patch
deleted file mode 100644
index 9ce8bd817..000000000
--- a/net/samplicator/patches/010-format.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/samplicate.c
-+++ b/samplicate.c
-@@ -560,7 +560,7 @@ samplicate (ctx)
- }
- if (len != sizeof remote_address)
- {
-- fprintf (stderr, "recvfrom() return address length %d - expected %d\n",
-+ fprintf (stderr, "recvfrom() return address length %d - expected %zu\n",
- len, sizeof remote_address);
- exit (1);
- }