aboutsummaryrefslogtreecommitdiff
path: root/net/opennhrp
diff options
context:
space:
mode:
Diffstat (limited to 'net/opennhrp')
-rw-r--r--net/opennhrp/Makefile4
-rw-r--r--net/opennhrp/patches/100-musl-compat.patch20
2 files changed, 22 insertions, 2 deletions
diff --git a/net/opennhrp/Makefile b/net/opennhrp/Makefile
index 449e0a6fb..4c2b9e827 100644
--- a/net/opennhrp/Makefile
+++ b/net/opennhrp/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2009-2011 OpenWrt.org
+# Copyright (C) 2009-2015 OpenWrt.org
# Copyright (C) 2009 Jakob Pfeiffer
# Copyright (C) 2014 Artem Makhutov
#
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=opennhrp
PKG_VERSION:=0.14.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=Artem Makhutov <artem@makhutov.org>
PKG_LICENSE:=MIT License
diff --git a/net/opennhrp/patches/100-musl-compat.patch b/net/opennhrp/patches/100-musl-compat.patch
new file mode 100644
index 000000000..8be0f7130
--- /dev/null
+++ b/net/opennhrp/patches/100-musl-compat.patch
@@ -0,0 +1,20 @@
+--- a/nhrp/opennhrp.c
++++ b/nhrp/opennhrp.c
+@@ -9,6 +9,7 @@
+ #include <ctype.h>
+ #include <stdio.h>
+ #include <errno.h>
++#include <fcntl.h>
+ #include <malloc.h>
+ #include <stddef.h>
+ #include <string.h>
+--- a/nhrp/nhrp_common.h
++++ b/nhrp/nhrp_common.h
+@@ -12,6 +12,7 @@
+ #include <stdint.h>
+ #include <stdlib.h>
+ #include <sys/time.h>
++#include <sys/types.h>
+ #include <linux/if_ether.h>
+
+ struct nhrp_interface;