aboutsummaryrefslogtreecommitdiff
path: root/net/ntpd
diff options
context:
space:
mode:
Diffstat (limited to 'net/ntpd')
-rw-r--r--net/ntpd/Makefile2
-rw-r--r--net/ntpd/files/ntpdate.init4
2 files changed, 4 insertions, 2 deletions
diff --git a/net/ntpd/Makefile b/net/ntpd/Makefile
index e98924a7a..d1f7d5d7b 100644
--- a/net/ntpd/Makefile
+++ b/net/ntpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ntp
PKG_VERSION:=4.2.8p13
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/
diff --git a/net/ntpd/files/ntpdate.init b/net/ntpd/files/ntpdate.init
index 2f332104d..30460e5ae 100644
--- a/net/ntpd/files/ntpdate.init
+++ b/net/ntpd/files/ntpdate.init
@@ -3,7 +3,9 @@
START=60
-STEP_SERVERS="0.openwrt.pool.ntp.org 1.openwrt.pool.ntp.org 2.openwrt.pool.ntp.org"
+DEFAULT_SERVERS="0.openwrt.pool.ntp.org 1.openwrt.pool.ntp.org 2.openwrt.pool.ntp.org"
+CFG_SERVERS=$(uci -q get system.ntp.server)
+STEP_SERVERS=${CFG_SERVERS:-$DEFAULT_SERVERS}
TIMEOUT="2" # in seconds
start() {