aboutsummaryrefslogtreecommitdiff
path: root/net/libreswan/patches
diff options
context:
space:
mode:
Diffstat (limited to 'net/libreswan/patches')
-rw-r--r--net/libreswan/patches/010-nanosleep.patch8
-rw-r--r--net/libreswan/patches/020-limits.patch4
-rw-r--r--net/libreswan/patches/030-fix_musl_build.patch4
-rw-r--r--net/libreswan/patches/040-disable_man.patch6
4 files changed, 11 insertions, 11 deletions
diff --git a/net/libreswan/patches/010-nanosleep.patch b/net/libreswan/patches/010-nanosleep.patch
index 45481cd1b..c38b4dade 100644
--- a/net/libreswan/patches/010-nanosleep.patch
+++ b/net/libreswan/patches/010-nanosleep.patch
@@ -9,13 +9,13 @@
#include <errno.h>
#include "defs.h"
-@@ -180,7 +180,8 @@
- /* Send a duplicate packet when this impair is enabled - used for testing */
- if (IMPAIR(JACOB_TWO_TWO)) {
+@@ -192,7 +192,8 @@ static bool send_chunks(const char *wher
+ */
+ if (impair.jacob_two_two) {
/* sleep for half a second, and second another packet */
- usleep(500000);
+ const struct timespec req = {0, 500 * 1000 * 1000};
+ nanosleep(&req, NULL);
endpoint_buf b;
endpoint_buf ib;
- DBG_log("JACOB 2-2: resending %zu bytes for %s through %s from %s to %s:",
+ llog(RC_LOG, logger,
diff --git a/net/libreswan/patches/020-limits.patch b/net/libreswan/patches/020-limits.patch
index 5a5635698..20d86cb80 100644
--- a/net/libreswan/patches/020-limits.patch
+++ b/net/libreswan/patches/020-limits.patch
@@ -16,5 +16,5 @@
#include <unistd.h> /* for gethostname() */
+#include <limits.h>
- #include <libreswan.h>
- #include "libreswan/pfkeyv2.h"
+ #include <event2/event.h>
+ #include <event2/event_struct.h>
diff --git a/net/libreswan/patches/030-fix_musl_build.patch b/net/libreswan/patches/030-fix_musl_build.patch
index 7183a1989..1f0baad9e 100644
--- a/net/libreswan/patches/030-fix_musl_build.patch
+++ b/net/libreswan/patches/030-fix_musl_build.patch
@@ -1,5 +1,5 @@
---- a/include/fd.h 2020-10-25 12:29:43.527467613 +0200
-+++ b/include/fd.h 2020-10-25 12:27:41.043595114 +0200
+--- a/include/fd.h
++++ b/include/fd.h
@@ -26,6 +26,7 @@
#include <stdbool.h>
diff --git a/net/libreswan/patches/040-disable_man.patch b/net/libreswan/patches/040-disable_man.patch
index 92850d532..42a5c3364 100644
--- a/net/libreswan/patches/040-disable_man.patch
+++ b/net/libreswan/patches/040-disable_man.patch
@@ -1,6 +1,6 @@
---- a/mk/targets.mk 2020-10-25 12:47:38.504784276 +0200
-+++ b/mk/targets.mk 2020-10-25 12:48:16.242123361 +0200
-@@ -64,7 +64,7 @@
+--- a/mk/targets.mk
++++ b/mk/targets.mk
+@@ -64,7 +64,7 @@ endef
#
# For each define: TARGET clean-TARGET install-TARGET