aboutsummaryrefslogtreecommitdiff
path: root/net/keepalived/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/keepalived/Makefile')
-rw-r--r--net/keepalived/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/net/keepalived/Makefile b/net/keepalived/Makefile
index 3665df834..2e782e81a 100644
--- a/net/keepalived/Makefile
+++ b/net/keepalived/Makefile
@@ -33,7 +33,6 @@ PKG_CONFIG_DEPENDS:= \
CONFIG_KEEPALIVED_SNMP_RFC3 \
CONFIG_KEEPALIVED_SNMP_REPLY_V3_FOR_V2 \
CONFIG_KEEPALIVED_DBUS \
- CONFIG_KEEPALIVED_JSON \
CONFIG_KEEPALIVED_ROUTES \
CONFIG_IPV6
@@ -58,6 +57,8 @@ define Package/keepalived
+libnl-genl \
+libmagic \
+libkmod \
+ +kmod-nf-ipvs \
+ +libjson-c \
+KEEPALIVED_NFTABLES:libnftnl \
+KEEPALIVED_VRRP:kmod-macvlan \
+KEEPALIVED_VRRP:libnl-route \
@@ -68,7 +69,6 @@ define Package/keepalived
+KEEPALIVED_IPTABLES:libxtables \
+KEEPALIVED_IPTABLES:libipset \
+(KEEPALIVED_SNMP_VRRP||KEEPALIVED_SNMP_CHECKER||KEEPALIVED_SNMP_RFC2||KEEPALIVED_SNMP_RFC3):libnetsnmp \
- +KEEPALIVED_JSON:libjson-c \
+KEEPALIVED_DBUS:glib2
endef
@@ -83,6 +83,7 @@ define Package/keepalived/conffiles
endef
CONFIGURE_ARGS+= \
+ --enable-json \
--with-init=SYSV \
--disable-track-process \
--runstatedir="/var/run"
@@ -147,11 +148,6 @@ CONFIGURE_ARGS += \
endif
endif # CONFIG_KEEPALIVED_SNMP_RFC3
-ifeq ($(CONFIG_KEEPALIVED_JSON),y)
-CONFIGURE_ARGS += \
- --enable-json
-endif
-
ifeq ($(CONFIG_KEEPALIVED_VRRP_AUTH),)
CONFIGURE_ARGS += \
--disable-vrrp-auth
@@ -241,6 +237,10 @@ endif
$(INSTALL_DATA) ./files/hotplug-user \
$(1)/etc/hotplug.d/keepalived/01-user
+ $(INSTALL_DIR) $(1)/usr/libexec/rpcd
+ $(INSTALL_BIN) ./files/usr/libexec/rpcd/keepalived \
+ $(1)/usr/libexec/rpcd/keepalived
+
ifneq ($(CONFIG_KEEPALIVED_SNMP_VRRP)$(CONFIG_KEEPALIVED_SNMP_CHECKER)$(CONFIG_KEEPALIVED_SNMP_RFC2)$(CONFIG_KEEPALIVED_SNMP_RFC3),)
$(INSTALL_DIR) $(1)/usr/share/snmp/mibs
endif