aboutsummaryrefslogtreecommitdiff
path: root/net/kea
diff options
context:
space:
mode:
Diffstat (limited to 'net/kea')
-rw-r--r--net/kea/Makefile2
-rw-r--r--net/kea/patches/010-openssl-deprecated.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/net/kea/Makefile b/net/kea/Makefile
index 8ce9823c5..c60ba9d1b 100644
--- a/net/kea/Makefile
+++ b/net/kea/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=kea
PKG_VERSION:=1.5.0
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://ftp.isc.org/isc/kea/$(PKG_VERSION)
diff --git a/net/kea/patches/010-openssl-deprecated.patch b/net/kea/patches/010-openssl-deprecated.patch
new file mode 100644
index 000000000..c8b438efc
--- /dev/null
+++ b/net/kea/patches/010-openssl-deprecated.patch
@@ -0,0 +1,11 @@
+--- a/src/lib/cryptolink/openssl_link.cc
++++ b/src/lib/cryptolink/openssl_link.cc
+@@ -79,7 +79,7 @@ CryptoLink::initialize() {
+
+ std::string
+ CryptoLink::getVersion() {
+- return (SSLeay_version(SSLEAY_VERSION));
++ return (OpenSSL_version(OPENSSL_VERSION));
+ }
+
+ } // namespace cryptolink