aboutsummaryrefslogtreecommitdiff
path: root/net/kadnode/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/kadnode/Makefile')
-rw-r--r--net/kadnode/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/net/kadnode/Makefile b/net/kadnode/Makefile
index d4b22ce12..5db3247e8 100644
--- a/net/kadnode/Makefile
+++ b/net/kadnode/Makefile
@@ -76,6 +76,10 @@ endif
MAKE_FLAGS += FEATURES="$(FEATURES)"
+# Make binary smaller
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -Wl,--gc-sections
+
define Package/kadnode/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/build/kadnode $(1)/usr/bin/