aboutsummaryrefslogtreecommitdiff
path: root/net/haproxy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/haproxy/Makefile')
-rw-r--r--net/haproxy/Makefile15
1 files changed, 3 insertions, 12 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index ca86759b8..23306e92a 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -10,12 +10,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=haproxy
-PKG_VERSION:=2.1.7
+PKG_VERSION:=2.2.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://www.haproxy.org/download/2.1/src
-PKG_HASH:=392e6cf18e75fe7e166102e8c4512942890a0b5ae738f6064faab4687f60a339
+PKG_SOURCE_URL:=https://www.haproxy.org/download/2.2/src
+PKG_HASH:=536552af1316807c01de727ad3dac84b3a2f5285db32e9bfdfe234e47ff9d124
PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>, \
Christian Lachner <gladiac@gmail.com>
@@ -79,11 +79,6 @@ $(call Package/haproxy/Default/description)
endef
ENABLE_LUA:=y
-ENABLE_REGPARM:=n
-
-ifeq ($(CONFIG_TARGET_x86),y)
- ENABLE_REGPARM:=y
-endif
ifeq ($(CONFIG_USE_UCLIBC),y)
ADDON+=USE_LIBCRYPT=
@@ -94,10 +89,6 @@ ifeq ($(BUILD_VARIANT),ssl)
ADDON+=ADDLIB="-lcrypto -lm"
endif
-ifeq ($(ENABLE_REGPARM),y)
- ADDON+=USE_REGPARM=1
-endif
-
define Build/Compile
$(MAKE) TARGET=linux-glibc -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \