aboutsummaryrefslogtreecommitdiff
path: root/net/fakepop/patches/010-fPIC.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net/fakepop/patches/010-fPIC.patch')
-rw-r--r--net/fakepop/patches/010-fPIC.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/net/fakepop/patches/010-fPIC.patch b/net/fakepop/patches/010-fPIC.patch
new file mode 100644
index 000000000..dec12dd9f
--- /dev/null
+++ b/net/fakepop/patches/010-fPIC.patch
@@ -0,0 +1,13 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,8 +2,8 @@
+
+ GLIB_CFLAGS = $(shell pkg-config --cflags glib-2.0)
+ GLIB_LDFLAGS = $(shell pkg-config --libs glib-2.0)
+-CFLAGS = -D_GNU_SOURCE -Wall -O2 $(GLIB_CFLAGS)
+-LDLIBS = $(GLIB_LDFLAGS)
++CFLAGS += $(GLIB_CFLAGS)
++LDLIBS += $(GLIB_LDFLAGS)
+
+ all: fakepop
+