aboutsummaryrefslogtreecommitdiff
path: root/net/dynapoint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/dynapoint/Makefile')
-rw-r--r--net/dynapoint/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/net/dynapoint/Makefile b/net/dynapoint/Makefile
new file mode 100644
index 000000000..ca32cd1dc
--- /dev/null
+++ b/net/dynapoint/Makefile
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2016 Tobias Ilte <tobias.ilte@campus.tu-berlin.de>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=dynapoint
+PKG_RELEASE:=1
+
+PKG_MAINTAINER:=Tobias Ilte <tobias.ilte@campus.tu-berlin.de>
+PKG_LICENSE:=GPL-3.0+
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/$(PKG_NAME)
+ SECTION:=net
+ CATEGORY:=Network
+ SUBMENU:=wireless
+ DEPENDS:=+lua +libubus-lua +libuci-lua +libubox-lua +luci-lib-nixio
+ TITLE:=Dynamic access point manager
+endef
+
+define Package/$(PKG_NAME)/description
+ Dynapoint uses LUA scripts to allow dynamic access point creation
+ and deletion depending on changes of certain network conditions.
+endef
+
+define Package/$(PKG_NAME)/conffiles
+/etc/config/dynapoint
+endef
+
+define Build/Compile
+endef
+
+define Package/$(PKG_NAME)/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) ./src/dynapoint.lua $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./src/dynapoint.init $(1)/etc/init.d/dynapoint
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_DATA) ./src/dynapoint.config $(1)/etc/config/dynapoint
+endef
+
+$(eval $(call BuildPackage,$(PKG_NAME)))