aboutsummaryrefslogtreecommitdiff
path: root/net/dcstad
diff options
context:
space:
mode:
Diffstat (limited to 'net/dcstad')
-rw-r--r--net/dcstad/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/dcstad/Makefile b/net/dcstad/Makefile
index 3112b0c1c..bd07a8e4a 100644
--- a/net/dcstad/Makefile
+++ b/net/dcstad/Makefile
@@ -22,6 +22,7 @@ PKG_LICENSE_FILES:=COPYING
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
+PKG_BUILD_FLAGS:=gc-sections
include $(INCLUDE_DIR)/package.mk
@@ -38,8 +39,7 @@ define Package/dcstad/description
Implementation of the Dual-Channel WiFi client daemon
endef
-TARGET_CFLAGS += -ffunction-sections -fdata-sections -flto
-TARGET_LDFLAGS += -Wl,--gc-sections
+TARGET_CFLAGS += -flto
define Package/dcstad/install
$(INSTALL_DIR) $(1)/bin