aboutsummaryrefslogtreecommitdiff
path: root/net/bonding/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/bonding/Makefile')
-rw-r--r--net/bonding/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/net/bonding/Makefile b/net/bonding/Makefile
new file mode 100644
index 000000000..c808666b3
--- /dev/null
+++ b/net/bonding/Makefile
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2018 TDT AG <development@tdt.de>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See https://www.gnu.org/licenses/gpl-2.0.txt for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=proto-bonding
+PKG_VERSION:=2018-06-11
+PKG_RELEASE:=1
+
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=
+
+PKG_MAINTAINER:=Helge Mader <ma@dev.tdt.de>
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/proto-bonding
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Link Aggregation (Channel Bonding) proto handler
+ DEPENDS:=+kmod-bonding
+endef
+
+define Package/proto-bonding/description
+ This package contains the channel bonding proto handler for netifd
+endef
+
+define Build/Compile
+endef
+
+define Package/proto-bonding/install
+ $(INSTALL_DIR) $(1)/lib/netifd/proto/
+ $(INSTALL_BIN) ./files/lib/netifd/proto/bonding.sh \
+ $(1)/lib/netifd/proto/
+endef
+
+$(eval $(call BuildPackage,proto-bonding))