aboutsummaryrefslogtreecommitdiff
path: root/net/bind/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/bind/Makefile')
-rw-r--r--net/bind/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/net/bind/Makefile b/net/bind/Makefile
index df952d66d..4484e42d6 100644
--- a/net/bind/Makefile
+++ b/net/bind/Makefile
@@ -96,7 +96,8 @@ define Package/bind-tools
+bind-nslookup \
+bind-dnssec \
+bind-host \
- +bind-rndc
+ +bind-rndc \
+ +bind-ddns-confgen
endef
define Package/bind-rndc
@@ -131,6 +132,11 @@ define Package/bind-nslookup
200:/usr/bin/nslookup:/usr/libexec/nslookup-bind
endef
+define Package/bind-ddns-confgen
+ $(call Package/bind/Default)
+ TITLE+= administration tools (ddns-confgen and tsig-keygen only)
+endef
+
export BUILD_CC="$(TARGET_CC)"
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
@@ -259,6 +265,12 @@ define Package/bind-nslookup/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/nslookup $(1)/usr/libexec/nslookup-bind
endef
+define Package/bind-ddns-confgen/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ddns-confgen $(1)/usr/sbin/ddns-confgen
+ $(LN) -s ddns-confgen $(1)/usr/sbin/tsig-keygen
+endef
+
$(eval $(call BuildPackage,bind-libs))
$(eval $(call BuildPackage,bind-server))
$(eval $(call BuildPackage,bind-server-filter-aaaa))
@@ -270,3 +282,4 @@ $(eval $(call BuildPackage,bind-dnssec))
$(eval $(call BuildPackage,bind-host))
$(eval $(call BuildPackage,bind-dig))
$(eval $(call BuildPackage,bind-nslookup))
+$(eval $(call BuildPackage,bind-ddns-confgen))