aboutsummaryrefslogtreecommitdiff
path: root/net/beanstalkd/patches
diff options
context:
space:
mode:
Diffstat (limited to 'net/beanstalkd/patches')
-rw-r--r--net/beanstalkd/patches/900-makefile.patch6
-rw-r--r--net/beanstalkd/patches/901-fix-headers.patch4
-rw-r--r--net/beanstalkd/patches/902-replace-posix_fallocate.patch2
3 files changed, 5 insertions, 7 deletions
diff --git a/net/beanstalkd/patches/900-makefile.patch b/net/beanstalkd/patches/900-makefile.patch
index f948851e2..3cac7178b 100644
--- a/net/beanstalkd/patches/900-makefile.patch
+++ b/net/beanstalkd/patches/900-makefile.patch
@@ -1,5 +1,3 @@
-diff --git a/Makefile b/Makefile
-index a3f345f..fe5a083 100644
--- a/Makefile
+++ b/Makefile
@@ -1,17 +1,16 @@
@@ -91,7 +89,7 @@ index a3f345f..fe5a083 100644
bench: ct/_ctcheck
ct/_ctcheck -b
-@@ -88,11 +79,8 @@ ct/ct.o ct/_ctcheck.o: ct/ct.h ct/internal.h
+@@ -88,11 +79,8 @@ ct/ct.o ct/_ctcheck.o: ct/ct.h ct/intern
$(TOFILES): $(HFILES) ct/ct.h
@@ -104,7 +102,7 @@ index a3f345f..fe5a083 100644
vers.c:
./verc.sh >vers.c
-@@ -100,3 +88,9 @@ doc/beanstalkd.1 doc/beanstalkd.1.html: doc/beanstalkd.ronn
+@@ -100,3 +88,9 @@ doc/beanstalkd.1 doc/beanstalkd.1.html:
ronn $<
freebsd.o: darwin.c
diff --git a/net/beanstalkd/patches/901-fix-headers.patch b/net/beanstalkd/patches/901-fix-headers.patch
index ba6de6d78..3c97abce7 100644
--- a/net/beanstalkd/patches/901-fix-headers.patch
+++ b/net/beanstalkd/patches/901-fix-headers.patch
@@ -1,5 +1,5 @@
---- a/sd-daemon.c 2017-02-16 18:50:20.000000000 -0700
-+++ b/sd-daemon.c 2017-02-16 19:21:09.086008361 -0700
+--- a/sd-daemon.c
++++ b/sd-daemon.c
@@ -32,7 +32,7 @@
#include <sys/stat.h>
#include <sys/socket.h>
diff --git a/net/beanstalkd/patches/902-replace-posix_fallocate.patch b/net/beanstalkd/patches/902-replace-posix_fallocate.patch
index 18b07c188..3371ff438 100644
--- a/net/beanstalkd/patches/902-replace-posix_fallocate.patch
+++ b/net/beanstalkd/patches/902-replace-posix_fallocate.patch
@@ -7,7 +7,7 @@
#include <stdint.h>
#include <fcntl.h>
#include <stdlib.h>
-@@ -19,7 +19,7 @@ static int epfd;
+@@ -19,7 +21,7 @@ static int epfd;
int
rawfalloc(int fd, int len)
{