aboutsummaryrefslogtreecommitdiff
path: root/net/acme
diff options
context:
space:
mode:
Diffstat (limited to 'net/acme')
-rw-r--r--net/acme/Makefile2
-rw-r--r--net/acme/files/run.sh10
2 files changed, 11 insertions, 1 deletions
diff --git a/net/acme/Makefile b/net/acme/Makefile
index 158037e9e..d62cce0c9 100644
--- a/net/acme/Makefile
+++ b/net/acme/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=acme
PKG_VERSION:=2.8.6
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/acmesh-official/acme.sh/archive/$(PKG_VERSION).tar.gz
diff --git a/net/acme/files/run.sh b/net/acme/files/run.sh
index eccd3cb18..5c9361f4f 100644
--- a/net/acme/files/run.sh
+++ b/net/acme/files/run.sh
@@ -77,6 +77,11 @@ pre_checks()
case "$cmd" in
uhttpd)
+ if [ -n "$UHTTPD_LISTEN_HTTP" ]; then
+ debug "Already handled uhttpd; skipping"
+ continue
+ fi
+
debug "Found uhttpd listening on port 80; trying to disable."
UHTTPD_LISTEN_HTTP=$(uci get uhttpd.main.listen_http)
@@ -96,6 +101,11 @@ pre_checks()
fi
;;
nginx*)
+ if [ "$NGINX_WEBSERVER" -eq "1" ]; then
+ debug "Already handled nginx; skipping"
+ continue
+ fi
+
debug "Found nginx listening on port 80; trying to disable."
NGINX_WEBSERVER=1
local tries=0