aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
Diffstat (limited to 'libs')
-rw-r--r--libs/boost/Makefile4
-rw-r--r--libs/glib2/Makefile2
-rw-r--r--libs/libgd/Makefile2
-rw-r--r--libs/libgee/Makefile4
-rw-r--r--libs/libgpg-error/Makefile2
-rw-r--r--libs/libmraa/Makefile4
-rw-r--r--libs/libupm/Makefile4
-rw-r--r--libs/libxslt/Makefile2
-rw-r--r--libs/libzdb/Makefile4
-rw-r--r--libs/libzdb/patches/020-filterh-use-host-built-version.patch2
-rw-r--r--libs/postgresql/Makefile8
-rw-r--r--libs/protobuf/Makefile2
12 files changed, 20 insertions, 20 deletions
diff --git a/libs/boost/Makefile b/libs/boost/Makefile
index d645a3d3d..45e9c6282 100644
--- a/libs/boost/Makefile
+++ b/libs/boost/Makefile
@@ -417,11 +417,11 @@ endef
define Host/Install
$(INSTALL_DIR) \
- $(STAGING_DIR)/host/bin
+ $(STAGING_DIR_HOSTPKG)/bin
$(CP) \
$(HOST_BUILD_DIR)/tools/build/src/engine/bin.*/b2 \
- $(STAGING_DIR)/host/bin/
+ $(STAGING_DIR_HOSTPKG)/bin/
endef
define Package/boost/Default/install
diff --git a/libs/glib2/Makefile b/libs/glib2/Makefile
index 013e23b16..48166e8fa 100644
--- a/libs/glib2/Makefile
+++ b/libs/glib2/Makefile
@@ -61,7 +61,7 @@ CONFIGURE_ARGS += \
CONFIGURE_VARS += \
glib_cv_stack_grows=no \
glib_cv_uscore=no \
- ac_cv_path_GLIB_GENMARSHAL=$(STAGING_DIR)/host/bin/glib-genmarshal \
+ ac_cv_path_GLIB_GENMARSHAL=$(STAGING_DIR_HOSTPKG)/bin/glib-genmarshal \
ac_cv_func_mmap_fixed_mapped=yes \
ac_cv_func_posix_getpwuid_r=yes \
ac_cv_func_posix_getgrgid_r=yes
diff --git a/libs/libgd/Makefile b/libs/libgd/Makefile
index 0309ff28c..374998264 100644
--- a/libs/libgd/Makefile
+++ b/libs/libgd/Makefile
@@ -54,7 +54,7 @@ CONFIGURE_ARGS += \
--without-iconv
CONFIGURE_VARS += \
- LIBPNG12_CONFIG="$(STAGING_DIR)/host/bin/libpng12-config" \
+ LIBPNG12_CONFIG="$(STAGING_DIR_HOSTPKG)/bin/libpng12-config" \
ac_cv_header_iconv_h=no
define Build/InstallDev
diff --git a/libs/libgee/Makefile b/libs/libgee/Makefile
index 9be56482d..27b353c16 100644
--- a/libs/libgee/Makefile
+++ b/libs/libgee/Makefile
@@ -57,10 +57,10 @@ define Build/InstallDev
$(INSTALL_DATA) \
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \
$(1)/usr/lib/pkgconfig/
- $(INSTALL_DIR) $(STAGING_DIR)/host/share/vala-0.30/vapi/
+ $(INSTALL_DIR) $(STAGING_DIR_HOSTPKG)/share/vala-0.30/vapi/
$(INSTALL_DATA) \
$(PKG_INSTALL_DIR)/usr/share/vala/vapi/* \
- $(STAGING_DIR)/host/share/vala-0.30/vapi
+ $(STAGING_DIR_HOSTPKG)/share/vala-0.30/vapi
endef
define Package/libgee/install
diff --git a/libs/libgpg-error/Makefile b/libs/libgpg-error/Makefile
index 27e5e0954..999058632 100644
--- a/libs/libgpg-error/Makefile
+++ b/libs/libgpg-error/Makefile
@@ -51,7 +51,7 @@ define Build/InstallDev
$(SED) \
's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
$(2)/bin/gpg-error-config
- ln -sf $(STAGING_DIR)/host/bin/gpg-error-config $(1)/usr/bin/gpg-error-config
+ ln -sf $(STAGING_DIR_HOSTPKG)/bin/gpg-error-config $(1)/usr/bin/gpg-error-config
$(INSTALL_DIR) $(1)/usr/include
$(INSTALL_DATA) \
diff --git a/libs/libmraa/Makefile b/libs/libmraa/Makefile
index 1bff5ff99..69085691b 100644
--- a/libs/libmraa/Makefile
+++ b/libs/libmraa/Makefile
@@ -28,8 +28,8 @@ include $(INCLUDE_DIR)/cmake.mk
CMAKE_OPTIONS=-DBUILDARCH=$(CONFIG_ARCH) \
-DENABLEEXAMPLES=0 \
- -DNODE_EXECUTABLE=$(STAGING_DIR)/host/bin/node \
- -DSWIG_DIR=$(STAGING_DIR)/host/bin
+ -DNODE_EXECUTABLE=$(STAGING_DIR_HOSTPKG)/bin/node \
+ -DSWIG_DIR=$(STAGING_DIR_HOSTPKG)/bin
TARGET_CFLAGS+=-I$(STAGING_DIR)/usr/include/node
diff --git a/libs/libupm/Makefile b/libs/libupm/Makefile
index c1eaad16e..cb7add6d9 100644
--- a/libs/libupm/Makefile
+++ b/libs/libupm/Makefile
@@ -36,8 +36,8 @@ UPM_MODULES:= \
th02 tm1637 tsl2561 ttp223 ublox6 uln200xa waterlevel wheelencoder wt5001 yg1006 zfm20
CMAKE_OPTIONS=-DBUILDARCH=$(CONFIG_ARCH) \
- -DNODE_EXECUTABLE=$(STAGING_DIR)/host/bin/node \
- -DSWIG_DIR=$(STAGING_DIR)/host/bin
+ -DNODE_EXECUTABLE=$(STAGING_DIR_HOSTPKG)/bin/node \
+ -DSWIG_DIR=$(STAGING_DIR_HOSTPKG)/bin
define Package/libupm/Default
SECTION:=libs
diff --git a/libs/libxslt/Makefile b/libs/libxslt/Makefile
index 955073a00..5ca407c4a 100644
--- a/libs/libxslt/Makefile
+++ b/libs/libxslt/Makefile
@@ -83,7 +83,7 @@ define Build/InstallDev/Xslt
$(PKG_INSTALL_DIR)/usr/bin/xslt-config \
$(2)/bin/
- ln -sf $(STAGING_DIR)/host/bin/xslt-config $(1)/usr/bin/xslt-config
+ ln -sf $(STAGING_DIR_HOSTPKG)/bin/xslt-config $(1)/usr/bin/xslt-config
$(SED) \
's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
diff --git a/libs/libzdb/Makefile b/libs/libzdb/Makefile
index a8fcf30c2..c4f38f45b 100644
--- a/libs/libzdb/Makefile
+++ b/libs/libzdb/Makefile
@@ -63,8 +63,8 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR)/host/bin
- $(CP) $(HOST_BUILD_DIR)/tools/bin/filterh $(STAGING_DIR)/host/bin/
+ $(INSTALL_DIR) $(STAGING_DIR_HOSTPKG)/bin
+ $(CP) $(HOST_BUILD_DIR)/tools/bin/filterh $(STAGING_DIR_HOSTPKG)/bin/
endef
$(eval $(call HostBuild))
diff --git a/libs/libzdb/patches/020-filterh-use-host-built-version.patch b/libs/libzdb/patches/020-filterh-use-host-built-version.patch
index 1edfd77b3..7495fbc0b 100644
--- a/libs/libzdb/patches/020-filterh-use-host-built-version.patch
+++ b/libs/libzdb/patches/020-filterh-use-host-built-version.patch
@@ -14,7 +14,7 @@ diff -rupN libzdb-3.0.orig/Makefile.am libzdb-3.0/Makefile.am
RE2C = @RE2C@
RE2CFLAGS = -b
-FILTERH = ./tools/bin/filterh
-+FILTERH = $(STAGING_DIR)/host/bin/filterh
++FILTERH = $(STAGING_DIR_HOSTPKG)/bin/filterh
AM_CPPFLAGS = $(CPPFLAGS) $(DBCPPFLAGS)
AM_CPPFLAGS += -Isrc -Isrc/util -Isrc/net -Isrc/db -Isrc/exceptions
diff --git a/libs/postgresql/Makefile b/libs/postgresql/Makefile
index f27fa1e39..05071468d 100644
--- a/libs/postgresql/Makefile
+++ b/libs/postgresql/Makefile
@@ -147,14 +147,14 @@ endef
define Host/Install
$(INSTALL_DIR) $(STAGING_DIR)/usr/bin/
$(INSTALL_BIN) $(HOST_BUILD_DIR)/src/bin/pg_config/pg_config $(STAGING_DIR)/usr/bin/
- $(INSTALL_DIR) $(STAGING_DIR)/host/bin/
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/src/interfaces/ecpg/preproc/ecpg $(STAGING_DIR)/host/bin/
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/src/timezone/zic $(STAGING_DIR)/host/bin/
+ $(INSTALL_DIR) $(STAGING_DIR_HOSTPKG)/bin/
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/src/interfaces/ecpg/preproc/ecpg $(STAGING_DIR_HOSTPKG)/bin/
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/src/timezone/zic $(STAGING_DIR_HOSTPKG)/bin/
endef
define Build/Configure
$(Build/Configure/Default)
- $(SED) 's@ECPG = ../../preproc/ecpg@ECPG = $(STAGING_DIR)/host/bin/ecpg@' $(PKG_BUILD_DIR)/src/interfaces/ecpg/test/Makefile.regress
+ $(SED) 's@ECPG = ../../preproc/ecpg@ECPG = $(STAGING_DIR_HOSTPKG)/bin/ecpg@' $(PKG_BUILD_DIR)/src/interfaces/ecpg/test/Makefile.regress
endef
TARGET_CFLAGS += $(FPIC) -lpthread
diff --git a/libs/protobuf/Makefile b/libs/protobuf/Makefile
index 1e70a12fc..93d538a0a 100644
--- a/libs/protobuf/Makefile
+++ b/libs/protobuf/Makefile
@@ -41,7 +41,7 @@ define Package/protobuf/description
of its internal RPC protocols and file formats.
endef
-CONFIGURE_ARGS += --with-protoc=$(STAGING_DIR)/host/bin/protoc
+CONFIGURE_ARGS += --with-protoc=$(STAGING_DIR_HOSTPKG)/bin/protoc
define Build/InstallDev
$(INSTALL_DIR) \