aboutsummaryrefslogtreecommitdiff
path: root/libs/nspr/patches/001-compile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'libs/nspr/patches/001-compile.patch')
-rw-r--r--libs/nspr/patches/001-compile.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/libs/nspr/patches/001-compile.patch b/libs/nspr/patches/001-compile.patch
new file mode 100644
index 000000000..63b697e7a
--- /dev/null
+++ b/libs/nspr/patches/001-compile.patch
@@ -0,0 +1,26 @@
+--- a/nspr/config/Makefile.in
++++ b/nspr/config/Makefile.in
+@@ -30,7 +30,6 @@ CSRCS = now.c
+
+ # This version hasn't been ported for us; the one in mozilla/config has
+ ifneq ($(OS_ARCH),OS2)
+-CSRCS += nsinstall.c
+
+ PLSRCS = nfspwd.pl
+ endif
+@@ -84,7 +83,6 @@ else
+ ifeq (,$(filter-out SYMBIAN WINCE,$(OS_ARCH)))
+ TARGETS = $(PROGS)
+ else
+-PROGS += $(OBJDIR)/nsinstall$(PROG_SUFFIX)
+ TARGETS = $(PROGS) $(PLSRCS:.pl=)
+ endif
+ endif
+@@ -114,6 +112,7 @@ endif
+ $(OBJDIR)/%$(PROG_SUFFIX): $(OBJDIR)/%.$(OBJ_SUFFIX)
+ @$(MAKE_OBJDIR)
+ $(CC) $(XCFLAGS) $< $(LDFLAGS) $(XLDOPTS) $(OUTOPTION)$@
++ gcc nsinstall.c -o nsinstall
+
+ install:: nspr.m4
+ $(NSINSTALL) -D $(DESTDIR)$(datadir)/aclocal