aboutsummaryrefslogtreecommitdiff
path: root/libs/ngtcp2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'libs/ngtcp2/Makefile')
-rw-r--r--libs/ngtcp2/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/libs/ngtcp2/Makefile b/libs/ngtcp2/Makefile
new file mode 100644
index 000000000..5d7ad9a0c
--- /dev/null
+++ b/libs/ngtcp2/Makefile
@@ -0,0 +1,39 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ngtcp2
+PKG_VERSION:=1.0.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/ngtcp2/ngtcp2/releases/download/v$(PKG_VERSION)/
+PKG_HASH:=a40b18af654baaebee3431af9bb4e347f40080bf1189d658ad53f8e66bf39da3
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=COPYING
+PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
+
+CMAKE_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/libngtcp2
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Implementation of QUIC protocol
+ URL:=https://nghttp2.org/ngtcp2
+ DEPENDS:=+libnghttp3 +libopenssl
+endef
+
+define Package/libngtcp2/description
+ ngtcp2 project is an effort to implement QUIC protocol which is now being discussed in IETF QUICWG for its standardization.
+endef
+
+CMAKE_OPTIONS += -DENABLE_LIB_ONLY=ON
+
+define Package/libngtcp2/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libngtcp2*.so* $(1)/usr/lib
+endef
+
+$(eval $(call BuildPackage,libngtcp2))