aboutsummaryrefslogtreecommitdiff
path: root/libs/libxslt
diff options
context:
space:
mode:
Diffstat (limited to 'libs/libxslt')
-rw-r--r--libs/libxslt/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/libs/libxslt/Makefile b/libs/libxslt/Makefile
index b31989e4a..3fe97df30 100644
--- a/libs/libxslt/Makefile
+++ b/libs/libxslt/Makefile
@@ -27,6 +27,7 @@ PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
define Package/libxslt
SECTION:=libs
@@ -126,6 +127,15 @@ define Build/InstallDev
$(if $(CONFIG_PACKAGE_libexslt),$(call Build/InstallDev/Exslt,$(1),$(2)))
endef
+HOST_CONFIGURE_ARGS+= \
+ --disable-silent-rules \
+ --enable-static \
+ --without-python \
+ --without-crypto \
+ --without-debug \
+ --without-mem-debug \
+ --without-debugger
+
define Package/libxslt/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) \
@@ -150,3 +160,4 @@ endef
$(eval $(call BuildPackage,libxslt))
$(eval $(call BuildPackage,libexslt))
$(eval $(call BuildPackage,xsltproc))
+$(eval $(call HostBuild))