aboutsummaryrefslogtreecommitdiff
path: root/libs/liboping
diff options
context:
space:
mode:
Diffstat (limited to 'libs/liboping')
-rw-r--r--libs/liboping/Makefile84
-rw-r--r--libs/liboping/patches/01-no-werror.patch11
2 files changed, 95 insertions, 0 deletions
diff --git a/libs/liboping/Makefile b/libs/liboping/Makefile
new file mode 100644
index 000000000..54b45474c
--- /dev/null
+++ b/libs/liboping/Makefile
@@ -0,0 +1,84 @@
+#
+# Copyright (C) 2009-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=liboping
+PKG_VERSION:=1.6.2
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+PKG_LICENSE:=GPL-2.0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://verplant.org/liboping/files
+PKG_MD5SUM:=64a6f31310093d2517cfe7f05aa011e0
+
+PKG_FIXUP:=autoreconf
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/liboping/Default
+ URL:=http://verplant.org/liboping/
+endef
+
+define Package/liboping
+$(call Package/liboping/Default)
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=C library to generate ICMP echo requests.
+endef
+
+define Package/oping
+$(call Package/liboping/Default)
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Send ICMP echo request to network hosts
+ DEPENDS+= +liboping
+endef
+
+define Package/noping
+$(call Package/liboping/Default)
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Ncurses application to send ICMP echo request to network hosts
+ DEPENDS+= +liboping +libncurses
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+ --without-perl-bindings \
+ --enable-shared \
+ --enable-static
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/oping.h $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/liboping.{a,so*} $(1)/usr/lib/
+endef
+
+define Package/liboping/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/liboping.so.* $(1)/usr/lib/
+endef
+
+define Package/oping/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/oping $(1)/usr/bin/
+endef
+
+define Package/noping/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/noping $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,liboping))
+$(eval $(call BuildPackage,oping))
+$(eval $(call BuildPackage,noping))
diff --git a/libs/liboping/patches/01-no-werror.patch b/libs/liboping/patches/01-no-werror.patch
new file mode 100644
index 000000000..85892849d
--- /dev/null
+++ b/libs/liboping/patches/01-no-werror.patch
@@ -0,0 +1,11 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS = foreign no-dependenci
+ SUBDIRS = mans
+
+ if COMPILER_IS_GCC
+-AM_CFLAGS = -Wall -Werror
++AM_CFLAGS = -Wall
+ endif
+
+ include_HEADERS = oping.h