aboutsummaryrefslogtreecommitdiff
path: root/libs/libdcwsocket
diff options
context:
space:
mode:
Diffstat (limited to 'libs/libdcwsocket')
-rw-r--r--libs/libdcwsocket/Makefile2
-rw-r--r--libs/libdcwsocket/patches/010-glibc.patch12
2 files changed, 13 insertions, 1 deletions
diff --git a/libs/libdcwsocket/Makefile b/libs/libdcwsocket/Makefile
index 73a4c3a62..28176a8ec 100644
--- a/libs/libdcwsocket/Makefile
+++ b/libs/libdcwsocket/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libdcwsocket
PKG_VERSION:=1.1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/ewsi/$(PKG_NAME)/tar.gz/v$(PKG_VERSION)?
diff --git a/libs/libdcwsocket/patches/010-glibc.patch b/libs/libdcwsocket/patches/010-glibc.patch
new file mode 100644
index 000000000..24cb24b78
--- /dev/null
+++ b/libs/libdcwsocket/patches/010-glibc.patch
@@ -0,0 +1,12 @@
+--- a/src/dcwsocket.c.linux
++++ b/src/dcwsocket.c.linux
+@@ -36,6 +36,9 @@
+ #include <linux/filter.h>
+ #include <arpa/inet.h>
+
++#ifndef SO_ATTACH_FILTER
++#define SO_ATTACH_FILTER 26
++#endif
+
+ #define ETHER_HEADERSIZE 14
+ #define CL3_HEADERSIZE 4