aboutsummaryrefslogtreecommitdiff
path: root/libs/icu
diff options
context:
space:
mode:
Diffstat (limited to 'libs/icu')
-rw-r--r--libs/icu/Makefile9
-rw-r--r--libs/icu/patches/010-max_align_t.patch6
2 files changed, 8 insertions, 7 deletions
diff --git a/libs/icu/Makefile b/libs/icu/Makefile
index b34c226f4..cc6b86fc3 100644
--- a/libs/icu/Makefile
+++ b/libs/icu/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=icu4c
-MAJOR_VERSION:=72
+MAJOR_VERSION:=73
MINOR_VERSION:=1
PKG_VERSION:=$(MAJOR_VERSION).$(MINOR_VERSION)
-PKG_RELEASE:=2
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(MAJOR_VERSION)_$(MINOR_VERSION)-src.tgz
PKG_SOURCE_URL:=https://github.com/unicode-org/icu/releases/download/release-$(MAJOR_VERSION)-$(MINOR_VERSION)
-PKG_HASH:=a2d2d38217092a7ed56635e34467f92f976b370e20182ad325edea6681a71d68
+PKG_HASH:=a457431de164b4aa7eca00ed134d00dfbf88a77c6986a10ae7774fc076bb8c45
PKG_LICENSE:=ICU
PKG_LICENSE_FILES:=LICENSE
@@ -25,6 +25,7 @@ PKG_MAINTAINER:=Hirokazu MORIKAWA <morikw2@gmail.com>
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
+HOST_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=icu/host
HOST_BUILD_DEPENDS:=python3/host
@@ -104,7 +105,7 @@ HOST_CONFIGURE_VARS:=
ifeq ($(HOST_OS),Darwin)
HOST_CONFIGURE_ARGS:= MacOSX
else
-HOST_CONFIGURE_ARGS:= Linux/gcc
+HOST_CONFIGURE_ARGS:= Linux/gcc
endif
HOST_CONFIGURE_ARGS+= \
--disable-debug \
diff --git a/libs/icu/patches/010-max_align_t.patch b/libs/icu/patches/010-max_align_t.patch
index e8bd7f4bb..5dcf56896 100644
--- a/libs/icu/patches/010-max_align_t.patch
+++ b/libs/icu/patches/010-max_align_t.patch
@@ -29,7 +29,7 @@
*pErrorCode=U_MEMORY_ALLOCATION_ERROR;
--- a/common/utext.cpp
+++ b/common/utext.cpp
-@@ -569,7 +569,7 @@ enum {
+@@ -572,7 +572,7 @@ enum {
struct ExtendedUText {
UText ut;
@@ -38,7 +38,7 @@
};
static const UText emptyText = UTEXT_INITIALIZER;
-@@ -584,7 +584,7 @@ utext_setup(UText *ut, int32_t extraSpac
+@@ -587,7 +587,7 @@ utext_setup(UText *ut, int32_t extraSpac
// We need to heap-allocate storage for the new UText
int32_t spaceRequired = sizeof(UText);
if (extraSpace > 0) {
@@ -46,7 +46,7 @@
+ spaceRequired = sizeof(ExtendedUText) + extraSpace - sizeof(max_align_t);
}
ut = (UText *)uprv_malloc(spaceRequired);
- if (ut == NULL) {
+ if (ut == nullptr) {
--- a/tools/toolutil/toolutil.cpp
+++ b/tools/toolutil/toolutil.cpp
@@ -267,7 +267,7 @@ struct UToolMemory {