aboutsummaryrefslogtreecommitdiff
path: root/libs/avahi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'libs/avahi/Makefile')
-rw-r--r--libs/avahi/Makefile32
1 files changed, 0 insertions, 32 deletions
diff --git a/libs/avahi/Makefile b/libs/avahi/Makefile
index 1ea497c56..88b51c32b 100644
--- a/libs/avahi/Makefile
+++ b/libs/avahi/Makefile
@@ -217,23 +217,6 @@ $(call Package/avahi/Default/description)
For more information please see the avahi documentation.
endef
-define Package/libavahi-compat-libdnssd
- $(call Package/avahi/Default)
- SECTION:=libs
- CATEGORY:=Libraries
- VARIANT:=dbus
- DEPENDS:=+libavahi-client
- TITLE+= (libdnssd)
-endef
-
-define Package/libavahi-compat-libdnssd/description
-$(call Package/avahi/Default/description)
- .
- This packages adds the libavahi-compat-libdnssd library.
- It also automatically adds the required libavahi-client package.
- For more information please see the avahi documentation.
-endef
-
define Package/avahi-utils
$(call Package/avahi/Default)
SUBMENU:=IP Addresses and Names
@@ -294,10 +277,6 @@ CONFIGURE_ARGS += \
--with-autoipd-group=nogroup
ifeq ($(BUILD_VARIANT),dbus)
-ifneq ($(CONFIG_PACKAGE_libavahi-compat-libdnssd),)
-CONFIGURE_ARGS += \
- --enable-compat-libdns_sd
-endif
CONFIGURE_ARGS += \
--enable-dbus
else
@@ -314,11 +293,6 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libavahi-* $(1)/usr/lib/
-ifneq ($(CONFIG_PACKAGE_libavahi-compat-libdnssd),)
-ifeq ($(BUILD_VARIANT),dbus)
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdns_sd* $(1)/usr/lib/
-endif
-endif
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
endef
@@ -341,11 +315,6 @@ define Package/libavahi-client/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libavahi-client.so.* $(1)/usr/lib/
endef
-define Package/libavahi-compat-libdnssd/install
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdns_sd.so* $(1)/usr/lib/
-endef
-
define Package/avahi-utils/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
@@ -393,7 +362,6 @@ define Package/avahi-dnsconfd/install
endef
$(eval $(call BuildPackage,libavahi-client))
-$(eval $(call BuildPackage,libavahi-compat-libdnssd))
$(eval $(call BuildPackage,avahi-utils))
$(eval $(call BuildPackage,libavahi-dbus-support))
$(eval $(call BuildPackage,libavahi-nodbus-support))