aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/python/docker-compose/Makefile55
-rw-r--r--lang/python/python-distro/Makefile35
-rw-r--r--lang/python/python-dockerpty/Makefile36
-rw-r--r--lang/python/python-dotenv/Makefile36
-rw-r--r--lang/python/python-jsonschema/Makefile34
5 files changed, 196 insertions, 0 deletions
diff --git a/lang/python/docker-compose/Makefile b/lang/python/docker-compose/Makefile
new file mode 100644
index 000000000..aa8d206e9
--- /dev/null
+++ b/lang/python/docker-compose/Makefile
@@ -0,0 +1,55 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=docker-compose
+PKG_VERSION:=1.26.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=docker-compose
+PKG_HASH:=7e836102d139aca667d6af53f0f4d942c9459ec24d6dd4f0203d74359b0fd311
+
+PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+PKG_USE_MIPS16:=0
+
+PYTHON3_PKG_SETUP_ARGS:=
+
+define Package/docker-compose
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Docker Compose
+ URL:=https://github.com/docker/compose
+ DEPENDS+=+docker-ce \
+ +python3 \
+ +python3-cached-property \
+ +python3-colorama \
+ +python3-distro \
+ +python3-distutils \
+ +python3-docopt \
+ +python3-docker \
+ +python3-dockerpty \
+ +python3-dotenv \
+ +python3-jsonschema \
+ +python3-pkg-resources \
+ +python3-requests \
+ +python3-setuptools \
+ +python3-six \
+ +python3-texttable \
+ +python3-websocket-client \
+ +python3-yaml
+ VARIANT:=python3
+endef
+
+define Package/docker-compose/description
+ Multi-container orchestration for Docker
+endef
+
+$(eval $(call Py3Package,docker-compose))
+$(eval $(call BuildPackage,docker-compose))
+$(eval $(call BuildPackage,docker-compose-src))
diff --git a/lang/python/python-distro/Makefile b/lang/python/python-distro/Makefile
new file mode 100644
index 000000000..e33dc8e66
--- /dev/null
+++ b/lang/python/python-distro/Makefile
@@ -0,0 +1,35 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-distro
+PKG_VERSION:=1.5.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=distro
+PKG_HASH:=0e58756ae38fbd8fc3020d54badb8eae17c5b9dcbed388b17bb55b8a5928df92
+
+PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-distro
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Distro - an OS platform information API
+ URL:=https://github.com/nir0s/distro
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-distro/description
+ A much more elaborate, renewed alternative implementation for Python's
+ platform.linux_distribution()
+endef
+
+$(eval $(call Py3Package,python3-distro))
+$(eval $(call BuildPackage,python3-distro))
+$(eval $(call BuildPackage,python3-distro-src))
diff --git a/lang/python/python-dockerpty/Makefile b/lang/python/python-dockerpty/Makefile
new file mode 100644
index 000000000..642572749
--- /dev/null
+++ b/lang/python/python-dockerpty/Makefile
@@ -0,0 +1,36 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-dockerpty
+PKG_VERSION:=0.4.1
+PKG_RELEASE:=1
+
+PYPI_NAME:=dockerpty
+PKG_HASH:=69a9d69d573a0daa31bcd1c0774eeed5c15c295fe719c61aca550ed1393156ce
+
+PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE.txt
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+PYTHON3_PKG_SETUP_ARGS:=
+
+define Package/python3-dockerpty
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Python library to use the pseudo-tty of a docker container
+ URL:=https://github.com/d11wtq/dockerpty
+ DEPENDS:=+python3-light +python3-docker +python3-six
+ VARIANT:=python3
+endef
+
+define Package/python3-dockerpty/description
+ Python library to use the pseudo-tty of a docker container
+endef
+
+$(eval $(call Py3Package,python3-dockerpty))
+$(eval $(call BuildPackage,python3-dockerpty))
+$(eval $(call BuildPackage,python3-dockerpty-src))
diff --git a/lang/python/python-dotenv/Makefile b/lang/python/python-dotenv/Makefile
new file mode 100644
index 000000000..1749baf83
--- /dev/null
+++ b/lang/python/python-dotenv/Makefile
@@ -0,0 +1,36 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-dotenv
+PKG_VERSION:=0.13.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=python-dotenv
+PKG_HASH:=3b9909bc96b0edc6b01586e1eed05e71174ef4e04c71da5786370cebea53ad74
+
+PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-dotenv
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Add .env support to your django/flask apps in development and deployments
+ URL:=http://github.com/theskumar/python-dotenv
+ DEPENDS:=+python3-light +python3-click
+ VARIANT:=python3
+endef
+
+define Package/python3-dotenv/description
+ A Python library which reads the key-value pair from .env file and adds them
+ to environment variable. It is great for managing app settings during
+ development and in production using 12-factor principles.
+endef
+
+$(eval $(call Py3Package,python3-dotenv))
+$(eval $(call BuildPackage,python3-dotenv))
+$(eval $(call BuildPackage,python3-dotenv-src))
diff --git a/lang/python/python-jsonschema/Makefile b/lang/python/python-jsonschema/Makefile
new file mode 100644
index 000000000..9f8551c97
--- /dev/null
+++ b/lang/python/python-jsonschema/Makefile
@@ -0,0 +1,34 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-jsonschema
+PKG_VERSION:=3.2.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=jsonschema
+PKG_HASH:=c8a85b28d377cc7737e46e2d9f2b4f44ee3c0e1deac6bf46ddefc7187d30797a
+
+PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=COPYING
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-jsonschema
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=An implementation of JSON Schema validation
+ URL:=https://github.com/Julian/jsonschema
+ DEPENDS:=+python3-light +python3-attrs +python3-six +python3-pyrsistent
+ VARIANT:=python3
+endef
+
+define Package/python3-jsonschema/description
+ jsonschema is an implementation of JSON Schema validation for Python.
+endef
+
+$(eval $(call Py3Package,python3-jsonschema))
+$(eval $(call BuildPackage,python3-jsonschema))
+$(eval $(call BuildPackage,python3-jsonschema-src))