aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-pip/Makefile4
-rw-r--r--lang/python/python-pip/test.sh5
2 files changed, 7 insertions, 2 deletions
diff --git a/lang/python/python-pip/Makefile b/lang/python/python-pip/Makefile
index 97a5326bc..7dee1f965 100644
--- a/lang/python/python-pip/Makefile
+++ b/lang/python/python-pip/Makefile
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-pip
-PKG_VERSION:=23.1.2
+PKG_VERSION:=23.2
PKG_RELEASE:=1
PYPI_NAME:=pip
-PKG_HASH:=0e7c86f486935893c708287b30bd050a36ac827ec7fe5e43fe7cb198dd835fba
+PKG_HASH:=a160a170f3331d9ca1a0247eb1cd79c758879f1f81158f9cd05bbb5df80bea5c
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE.txt
diff --git a/lang/python/python-pip/test.sh b/lang/python/python-pip/test.sh
new file mode 100644
index 000000000..10355b3e3
--- /dev/null
+++ b/lang/python/python-pip/test.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+[ "$1" = python3-pip ] || exit 0
+
+pip --version | grep -F "pip $PKG_VERSION "