aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-oauthlib/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/lang/python/python-oauthlib/Makefile b/lang/python/python-oauthlib/Makefile
index 7b413d90c..af94b9503 100644
--- a/lang/python/python-oauthlib/Makefile
+++ b/lang/python/python-oauthlib/Makefile
@@ -1,6 +1,4 @@
#
-# Copyright (C) 2007-2016 OpenWrt.org
-#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
@@ -9,25 +7,29 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-oauthlib
PKG_VERSION:=3.0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
+
+PKG_MAINTAINER:=Eneas U de Queiroz <cote2004-github@yahoo.com>
PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
PKG_SOURCE:=oauthlib-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/o/oauthlib
PKG_HASH:=0ce32c5d989a1827e3f1148f98b9085ed2370fc939bf524c9c851d8714797298
+
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-oauthlib-$(PKG_VERSION)
-PKG_UNPACK=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
include ../python3-package.mk
+PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
+
define Package/python-oauthlib/Default
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
- MAINTAINER:=Eneas U de Queiroz <cote2004-github@yahoo.com>
- TITLE:=A generic, spec-compliant, thorough implementation of the OAuth request-signing logic
+ TITLE:=OAuth request-signing logic for Python
URL:=https://github.com/oauthlib/oauthlib
endef
@@ -44,7 +46,8 @@ define Package/python3-oauthlib
endef
define Package/python-oauthlib/description
- A generic, spec-compliant, thorough implementation of the OAuth request-signing logic for Python
+ A generic, spec-compliant, thorough implementation of the OAuth request-signing
+ logic for Python
endef
define Package/python3-oauthlib/description